Flathead Games





General Forum
Topic: The Depths bugs
UsernameDate postedText
Rizban2013-11-15 14:28:12If you throw an item at a chest, it completely glitches out your inventory. Within a short time, the game freezes up and requires a hard restart of the device to get the device to respond. Tested on Android and BlackBerry but haven't had the opportunity to test on my iPad yet.
Rizban2013-11-15 14:30:43On my Android phone, there are strange flashes and other graphical glitches when the inventory is open, even when the above bug isn't activated.
Rizban2013-11-15 14:33:57Saved games occasionally disappear when the above chest/inventory glitch occurs.
Jimmy2013-11-15 17:16:36Save game loss sucks and hard reset is worrying, I figured I could crash the app, but not the OS. I thought I covered the chest situation, but apparently not, I'll test again. Curious to see how the iPad test goes... I haven't released an iOS version yet :)

I've seen graphical glitches on Android before, I'm probably doing something wrong, but it works on the one Android device I have, so I can't really debug it. I don't think the flashes, glitches are game-breaking, but they're probably annoying. If you're only seeing it in the inventory, I'll check that code, at least it narrows it down.
Rizban2013-11-16 07:34:23If you use a charm wand on your dog, he turns hostile after the effects end.
Jimmy2013-11-16 09:07:47Thanks for those. I fixed the crash with throwing items into chests and fixed the pet hostility. I'm putting the finishing touches on a "tap to move" input method, I'll post a new build once that's done.
Rizban2013-11-16 09:32:56How will that interact with ranged weapons?
Jimmy2013-11-16 10:26:43It's a bit of a pain. ATM, I have 2 separate buttons for shoot/examine. So, if you have a sword equipped, tapping on an enemy will walk you to that square (which you probably don't want to do, since the enemy will be moving), if you have throwing knives equipped as well, a 'shoot/stop shooting' button will appear that you can toggle. I think it's ok, a little clumsy but clear.

I haven't set it up yet, but I'm thinking if you have a bow equipped, tapping an empty square will move you there, tapping an enemy will shoot it. So the 'shoot' button should only appear for throwing knives.

'Examine/stop examining' works the same way, but will always be on screen.

Tapping a follower will swap spots(as it is now). So in the future if attacking friendlies serves a purpose, I'll need to rethink things. (safe mode toggle?)

I also want to avoid a difference between a quick tap, double tap and long hold, and avoid popping up a little option menu when you tap something.
Rizban2013-11-16 15:20:30The touch screen controls are wonky already. You definitely need to try to clean the current controls up a bit too. It's very frustrating for people with big fingers to go the right direction when using the d-pad.
Jimmy2013-11-16 16:54:52Agreed, I'll take another pass at the d-pad, make regions a bit bigger, and clean up the detection of which dir is pressed.

New controls are working quite well. I set it up to always shoot if you have a bow or knives and you tap an enemy. You have to switch to 'examine' mode to not shoot at them, like other input modes. One issue is you can't shoot at walls/doors/wells/NPCs/etc, but none had any affect ATM.
Rizban2013-11-17 12:17:52Chests that spawn next to wells and walls can drop their items in inaccessible locations.
Rizban2013-11-17 12:18:49It might be beneficial to display how much XP is needed to level up in the character sheet. A current/next model would work fine.
Rizban2013-11-17 12:42:11The walls of the shops and, more often, the temple have strange protrusions as seen here: http://imageshack.com/a/img24/1685/mif6.png
Rizban2013-11-17 13:03:46The inaccessible chest drop bug seems to happen most when it spawns next to the south wall. I just lost the chest items on the past three levels in a row due to this bug.
Jimmy2013-11-17 14:09:51k, fixed the chest bug, turns out my code for finding a nearby free square was a mess, should always work now. Thanks again.

I've seen the temple protrusions, it's part of my first attempt to drop templated rooms into the dungeon, it has a couple of issues, the one you mentioned and the priest thinking you're in his temple when your not or vice-versa, I think the carpet is considered outside the room when you reload. I'll look into those another time.
Rizban2013-12-29 09:04:01Using a Purify scroll on an already blessed weapon does not remove the bless; however, it appears to cause the weapon to stop doing bonus damage to undead.
Jimmy2013-12-30 13:45:47Just tried that out, I'm not seeing it. Purify leaves the bless status alone, as you pointed out, and there's only a single flag for blessed, so what you see in the inventory is what you get. If the weapon is blessed, there's an automatic double damage bonus to undead, complete with exclamation marks around the damage number. I tried it out a few times and didn't see it fail. I'll keep an eye out though, something else might have caused it.
Rizban2013-12-31 17:08:07Huh. I used it on a blessed +2 axe, and it stopped doing the double damage. Could it have something to do with it being in the off hand?
Jimmy2013-12-31 20:13:29You win. Offhand weapons never had a chance at critical hits, so the undead multiplier wasn't in that code. I added critical chances to offhand at half the normal rate, with the normal multipliers for undead and sleeping enemies, for the cases you miss with main weapon. Which means I now have to check if I removed the enemy evasion chance if it was sleeping/frozen/etc... inaccuracy can still lead to misses though.

Happy new year!
DeepOne2014-04-05 07:01:29It seems that in the latest version, there is a bug that causes the equipment screen to freeze once one uses scrolls like purify and enhance on other pieces of equipment. I encountered this on level 3, twice, and you now owe me one Blessed Enhance scroll, Jimmy. ;)
Jimmy2014-04-05 08:07:17Thanks for the info.

Are you on Android or BlackBerry? I just tested on PC and BlackBerry and I'm seeing the inventory is locked after using any "affect equipment" scrolls, but you can still back out and keep playing. You'd need to shut down the game and restart it to "unlock" the inventory screen.

I'll fix it now and post a build on Android, BB takes a day or two to get fixes up.
DeepOne2014-04-05 09:52:05You're up early on a Saturday. :) - I'm on BlackBerry; I'll also try the workaround you proposed, thanks!
Jimmy2014-04-05 16:39:58Ya, fairly early Saturday, had to go to work for the while. I just submitting an update with the fix and a couple of other fixes. The build should be live in a day or two assuming submission goes through. Thanks again for the info on the bug.

Reply
Login to post on forums